Installing
Centricity® Practice Solution

Version 11
December 2012
## Revision history

<table>
<thead>
<tr>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>December 2012</td>
<td>Updated for release 11.0</td>
</tr>
<tr>
<td>DOC1189398</td>
<td></td>
</tr>
<tr>
<td>July 2011</td>
<td>Updated for release 10.0</td>
</tr>
<tr>
<td>DOC0838709 Rev 2</td>
<td></td>
</tr>
<tr>
<td>December 2010</td>
<td>Updated for release 9.5</td>
</tr>
<tr>
<td>DOC0838709 Rev 2</td>
<td>Added:</td>
</tr>
<tr>
<td></td>
<td>• Added SQL Configuration for automatic startup and enabling TCP/IP.</td>
</tr>
<tr>
<td></td>
<td>• Added info for adding servers to local intranet zones</td>
</tr>
<tr>
<td></td>
<td>• Time synchronization</td>
</tr>
<tr>
<td></td>
<td>• Windows 7 or Vista camera set up</td>
</tr>
<tr>
<td>March 2010</td>
<td>Updated for release 9.0.3</td>
</tr>
<tr>
<td>DOC0838709 internal</td>
<td>Added location for <strong>GEMSDemo.txt</strong> and <strong>GEMSRole.txt</strong> files for the demo database.</td>
</tr>
<tr>
<td>September 2009</td>
<td>Updated for release 9.0.1</td>
</tr>
<tr>
<td>DOC0838709 Rev 2</td>
<td></td>
</tr>
<tr>
<td>June 2009</td>
<td>Original issue for version 9.0</td>
</tr>
<tr>
<td>DOC0838709 Rev 1</td>
<td></td>
</tr>
</tbody>
</table>
# Installing Centricity Practice Solution

- Documentation conventions 2
- Terminology 3
- Getting Started 5
- SQL Server 2008 R2 9
  - Configure SQL Server for performance and up time 9
  - Configure SQL Server 2008 R2 to run the client on the server 11
- Synchronize time 11
- Install server 12
- Install a workstation client 20
- Install a web site 17
- Install client on the Remote Desktop Services/Citrix server 23
- Testing the Citrix client installation 24
- Launch the Centricity Practice Solution client 25
- Import clinical kits 27
- Install optional server software 28
- About Data Transfer Station (DTS) 29
- Install Data Transfer Station (DTS) 30
- Running the DTS as a Service 32
- Install Millbrook Integration Kit (MIK) 34
- Configuring webcams for Windows 7 or Vista operating systems 38
- Setting up user security 39
- ServerSetup online help 39
- Anti-virus software 39
- Install biometric authentication on page 40
- About the Demo (evaluation) Database 42
- About ServerSetup product updates 45
- Remove the client from a workstation 48
This guide contains instructions for a first-time installation of Centricity Practice Solution

Documentation conventions

This document uses the following conventions to represent different types of information:

<table>
<thead>
<tr>
<th>This convention...</th>
<th>Means this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>monospaced type</td>
<td>Type this text exactly as it appears.</td>
</tr>
<tr>
<td>Chart &gt; Clinical Lists</td>
<td>Open the Chart folder and select the Clinical Lists item.</td>
</tr>
<tr>
<td>Ctrl + U</td>
<td>Hold down the Ctrl key while you press U, then release both keys.</td>
</tr>
<tr>
<td>italic type</td>
<td>A term that is being defined. When used in a path or command line, it is a variable that should be replaced with your specific site value.</td>
</tr>
<tr>
<td></td>
<td>Key information about a topic.</td>
</tr>
<tr>
<td>✓</td>
<td>Tip. Information about a shortcut or other convenient or optional information.</td>
</tr>
<tr>
<td>!!!</td>
<td>Information with an impact on software implementation or performance, or a potential risk of data loss.</td>
</tr>
</tbody>
</table>
Terminology

<table>
<thead>
<tr>
<th>This term...</th>
<th>Means this...</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Active Directory authentication</strong></td>
<td>The Active Directory authentication option validates a user’s login name and password against an Active Directory profile. With Active Directory authentication, all user login names, passwords, and security group associations are defined and maintained in Active Directory, but that information is also stored in the Centricity Practice Solution database, with an option to automatically create users when they first log into the application, and to synchronize the security group membership between the two.</td>
</tr>
<tr>
<td><strong>Application authentication</strong></td>
<td>The application authentication option validates a user’s login name and password against values stored in the Centricity Practice Solution database, via the Service Layer. User names, login IDs, and passwords are all managed within the application.</td>
</tr>
<tr>
<td><strong>Application server</strong></td>
<td>A Windows server running Service Layer and JBoss web server to handle all application tasks between user workstations and the database server, including application Web sites and Web services. Application server components can be combined with Data Exchange components.</td>
</tr>
<tr>
<td><strong>Centricity Clinical Gateway</strong></td>
<td>Centricity Clinical Gateway (CCG) provides seamless communications between Centricity products and external healthcare applications and systems. CCG may be required for exchanging data with external systems. CCG is optional. If used, it is installed to the Data Exchange server. Different versions of the gateway cannot be run on the same server.</td>
</tr>
<tr>
<td><strong>Centricity Practice Solution Web site</strong></td>
<td>A Web site used to launch the client application on networked workstations or terminals and hosted by the Service Layer and JBoss application server.</td>
</tr>
<tr>
<td><strong>Cloverleaf 5.7 MB (Multi-Byte) interface engine</strong></td>
<td>Part of Centricity Clinical Gateway, the Cloverleaf interface engine receives messages from internal and external sources in a variety of protocols. Messages are translated as required and routed to specified destinations. Cloverleaf interface engine and sites (interfaces) are required to exchange data. You can continue to use older versions of Cloverleaf on the same system if required for non-GE legacy applications.</td>
</tr>
<tr>
<td><strong>Database server</strong></td>
<td>The server that hosts the database that stores Centricity application data.</td>
</tr>
<tr>
<td><strong>Data Exchange server</strong></td>
<td>A Windows server used to manage data exchange with remote systems. Data Transfer Station, MIK, and Centricity Clinical Gateway may be installed to this server. In limited circumstances, some data exchange components can be installed to the Database server. For best results, GE recommends installing to a separate machine.</td>
</tr>
<tr>
<td>This term...</td>
<td>Means this...</td>
</tr>
<tr>
<td>-------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Data Transfer Station (DTS)</strong></td>
<td>Runs on a dedicated machine and automates clinical data transfers to and from external systems via LinkLogic and (optionally) Cloverleaf interface engine. Multiple instances of DTS can be implemented. GE recommends locating each instance on a separate machine.</td>
</tr>
<tr>
<td><strong>JBoss</strong></td>
<td>See Service Layer.</td>
</tr>
<tr>
<td><strong>KnowledgeBase</strong></td>
<td>Clinical content that is updated quarterly. KnowledgeBase updates formulary names, ICD codes, allergy custom lists, medication references and interaction information, and problem references (CPT codes and keywords).</td>
</tr>
<tr>
<td><strong>LinkLogic</strong></td>
<td>LinkLogic runs within the Centricity application and is used to exchange information with other health care information systems. LinkLogic imports demographics, documents, lab results, appointments, and references to external images into the Centricity database and exports application data for demographics, documents, observations, procedures, allergies, problems and clinical summaries.</td>
</tr>
<tr>
<td><strong>MIK (Millbrook Integration Kit)</strong></td>
<td>MIK is a service that automates business data transfers for Centricity PM. MIK is typically installed to the database server in a PM-only implementation. It is installed to the Data Exchange server in a joint EMR-PM implementation.</td>
</tr>
<tr>
<td><strong>Service Layer</strong></td>
<td>The Service Layer handles all application tasks between user workstations and the Database Server. It is a service-oriented architecture (SOA) Java-based application server (JBoss) with Web services interface that supports:</td>
</tr>
<tr>
<td><strong>Staging area/staging location</strong></td>
<td>The directory on the database server that contains the Centricity application and database files used in the installation process. The contents of the Centricity installation media is copied to this directory and remains there during and after installation. The database installation files can be copied to this directory as well. The staging directory should have at least 2 GB of free space.</td>
</tr>
</tbody>
</table>
Getting Started

Centricity Practice Solution users connect from their workstations via a Web interface to the database containing your patient records. An overview of the process is:

- Install Centricity Practice Solution database on a Database server which users can access from workstations connected to your network. This is a remote install launched from the Application server.
- Install the Application Web site (JBoss and the Service Layer) on a separate Application server that users log into to access the database.

!!! Do not install the application Web site on a WTS/Citrix server.

- If product updates or service packs are available, access them via the product Web site, then download and apply them to the server.
- Install and optionally update Centricity Practice Solution on workstations where users document patient visits and carry out practice management tasks.
- Install and configure separately licensed interfaces to share data with labs, hospitals, transcription services, insurance companies, and other external information systems.

Review planning and implementation resources

The following planning and implementation resources are available on your Centricity Practice Solution media and on the Centricity Practice Services Web site.

- Centricity Practice Solution Release Notes. Check these notes for release news. Includes a summary of new features, and any late breaking information.
- System Planning and Requirements for Centricity Practice Solution. This guide contains detailed system planning information and maintenance procedures.
- Configuring Environments for Centricity Practice Solution. This guide contains detailed hardware and software specifications.
- Calculating hardware requirements for Centricity Practice Solution. Use this Microsoft® Excel spreadsheet to fine-tune your hardware requirements. This tool is available on the Centricity Practice Services Web site. If you have 25 or more users, you should plan to use this tool.
- Installing Centricity Practice Solution. This guide contains instructions to install and set up Centricity Practice Solution for the first time.
- Upgrading to Centricity Practice Solution. This guide contains instructions for upgrading an existing installation to Centricity Practice Solution.
- Managing interfaces with Centricity Practice Solution. Includes resources to support import and export of clinical data and patient information to and from other systems, such as labs, transcription services, insurance companies, and other healthcare organizations.
- Installing and Maintaining Centricity Clinical Gateway. Refer to this manual to install the Centricity Clinical Gateway and Cloverleaf. This is optional software shipped on a separate disc.
Get technical support

For help with your installation:

- Contact Sales: Send email to inside.sales@med.ge.com to order your services for an upgrade.
- After hours installation assistance is available at a higher billable rate. To avoid these additional fees, schedule your installation between 7:am and 5:30 PM Central Standard Time (CST) (Monday - Friday).

To contact Centricity Practice Services

- Send an e-mail to centricitypmsservices@ge.com.
- Visit the Centricity Practice Solution Services Web site at http://centricitypractice.gehealthcare.com for access to all documentation, optional plug-ins and other downloads, information about training and other services.

Before you install

Before beginning the installation process:

1. Review your system requirements. Detailed specifications and planning information are available in Configuring Environments for Centricity Practice Solution available in Centricity Documentation library or on the Centricity Practice Solution site.
   - Review required software
   - Review recommended hardware for each of your servers and workstations
   - Review software/services prerequisites
   - Review optional software

   If there is an existing jobs.txt file when the website is updated (Apply Available Updates) or re-installed (ServerSetup > Advanced > Web Installation), it is saved as jobs.save.txt. Use a text editor to view or copy the lines as needed. The existing jobs.txt file is not saved if the website is Uninstalled (ServerSetup > Advanced > Web Uninstallation).

2. If you are installing into a virtual environment, perform the following:
   a. Shut down the virtual machine where you plan to install the software.
   b. Use your virtual machine manager/administration tool to allocate more memory to the virtual machine during the upgrade. Allow 8-16GB to improve the performance.
      This setting can be changed back after the installation.
   c. Start the virtual machine.
3 Confirm the database server and the application server names do not exceed 16 characters. Server names longer than 16 characters result in users not able to log in to the application.

4 Confirm access and administrative privileges on relevant servers and workstations:
   - You have full SQL Server administration privileges on the server and on workstations where you plan to install Centricity Practice Solution applications.
   - Windows Users with Group Administration rights must be added to the SQL Server 2008 R2 Security Users with sysadmin privileges.
     a Log in to SQL Server Management Studio.
     b Open Security > Logins.
     c Right click on the administration account you are going to use and select Properties.
     d Select Server Roles.
     e Enable sysadmin.
     f Click OK.
     g Close SQL Server Management Studio.
   - The Administrator account must be a member of the local server administrators group.
   - Your privileges do not expire after regular working hours.
   - You can access the network and the Internet on the server.
   - You can access shared network folders.
   - You have the names of the server and database to be created or updated.

To install from a network, you must have SQL tools installed on the workstation.

*If you removed administrator privileges from client workstations, you must restore them to install or upgrade.*
Installing Centricity Practice Solution

5 Gather licensing information and materials:
   a Product license code required for installation.

   If you do not have the license code or your customer ID required in the next step, contact your GE account representative or Value Added Reseller.

   You can also go to http://centricitypractice.gehealthcare.com for instructions for contacting Order Management. Your Centricity Practice Solution database installation cannot be completed without a product license code.

   b Important login names and passwords
      ■ Note the SQL Server System Administrator logon ID and password (for your dedicated server and network). Check your SQL Server documentation for defaults.
      ■ Create/confirm the Application Logon ID and password

   When you install Centricity Practice Solution the first time, you create a logon and password that SQL Server uses to access the Centricity Practice Solution database when launching the client application. Clinic users do not use this logon, but system administrators use it for database maintenance.

   c Installation discs required for installation:
      ■ Centricity Practice Solution
      ■ SQL Server 2008 R2 (if not installed)
SQL Server 2008 R2

1. Install Microsoft SQL Server 2008 R2. Consult the Microsoft documentation for detailed instructions. Ignore compatibility messages.

   !!! To install SQL Server 2008 R2 database on an alternate drive, make sure Database Services is highlighted when you click Browse to navigate to the drive. To locate other components such as Documentation on alternate drives, select each component (one at a time), then navigate to the desired drive.

2. Open Start > Administrative Tools > Server Manager.
3. Select Roles in the left pane.
4. In the right pane, verify .NET Framework 3.5.1 is installed as a Role Service. If it is not, use Add Roles to install it.

   If .NET 3.5.1 is not listed as an option, download and install the .NET Framework 4 from the Microsoft site. Use Add Roles to install it.

5. Reboot the server.
6. Download and install the latest SQL Server Service Pack and reboot.

Server Logon

The SQL Server Name is the name of the SQL Server where you are installing or upgrading Centricity Practice Solution. By default, the name displayed is the server where ServerSetup application is running. Click ... to navigate to different server on your network.

The User Name is the SQL Server login name. The default or assigned SQL user may be displayed here. You must have the SQL user password to continue.

Users connect from a workstation to the Web site to access the application database via the Internet or your Intranet.

Configure SQL Server for performance and up time

The following configurations are required to optimize Centricity Practice Solution performance and up time on Microsoft SQL Server 2008 R2. For best results, set these configurations before running the application for the first time.

- Follow GE recommendations for database server RAM, disk arrays, and disk and database file layout.
- For security purposes, SQL Server should log on as a dedicated administrator account (not the Local System account)
- Configure SQL Server
- Enable lock pages in memory option
Installing Centricity Practice Solution

Configure SQL Server

1. Open Microsoft SQL Server 2008R2 > Configuration Tools > SQL Server Configuration Manager.
2. Select SQL Server Services from the left pane.
3. Right click on SQL Server Agent (MSSQLSERVER) in the right pane and select Properties.
4. Click on the Service tab and set the Start Mode to Automatic.
5. Click OK to close the window.
6. Expand SQL Server Network Configuration in the left pane and select Protocols for MSSQLSERVER.
7. Right click on TCP/IP in the right pane and select Enable.
8. Close the SQL Server Configuration Manager.
9. Reboot the server.

Enable lock pages in memory option

This option improves performance by preventing the operating system from swapping SQL Server memory pages to disk and allowing SQL Server to reduce its working set when the OS requires it to do so.

From the database server:
1. On the Start menu, select Run.
2. In the Open field, type gpedit.msc. This command opens the Group Policy console.
4. In the right hand pane, double-click Lock Pages in Memory.
5. In the Local Security Policy Setting window, click Add User or Group...
6. Enter the account name with privileges to run sqlservr.exe.
7. Click OK to close the Local Security Policy Setting window.
8. Select File > Exit to close the Group Policy Object Editor.
9. Restart the SQL Server (instance) service.
Configure SQL Server 2008 R2 to run the client on the server

1. Open Microsoft SQL Server 2008R2 > SQL Server Management Studio.
2. Right click on the database instance and select Facets.
3. Select the Facet: Surface Area Configuration. Set each of the following features to True:
   - AdHocRemoteQueriesEnabled
   - ClrIntegrationEnabled
   - OleAutomationEnabled
   - RemoteDacEnabled
   - XPCmdShellEnabled
4. You can click Export Current State as Policy... to make these settings the policy for your enterprise.
5. Click OK to return to the main SQL Server Management Studio window.
6. Right click on the database instance and select Stop.
7. Once the service stops, click Start.
8. Click File > Exit to close the SQL Server Management Studio window.

Synchronize time

All servers and clients must be time synchronized with either Network Time Protocol (NTP) or Simple Network Time Protocol (SNTP). The best method for ensuring synchronization is to configure the domain controller and create a group policy for all clients.

1. Log on to the domain controller.
2. Open a command window and enter the following:
   ```
   net time /setsntp <time_server>
   ```
   Where `<time_server>` is the name or IP address of an accessible time server, for example: `time.nist.gov`
3. Create a group policy. Information is available on the Microsoft site: Windows Time Service Group Policy.

Disable Internet Protocol Version 6 (TCP/IPv6)

If your site does not use TCP/IPv6, disabling the component improves Centricity Practice Solution performance. For each server/workstation, including virtual machines:

1. Open the Local Area Connection Properties.
2. On the Networking tab for each adaptor, uncheck the option Internet Protocol Version 6 (TCP/IPv6).

   Reboot if prompted.
Installing Centricity Practice Solution

Install server

1. Insert the **Centricity Practice Solution** installation disc in the drive.

   If you are using a downloaded file in place of the installation disc, extract the .zip archive into a new folder. Open the new folder\Disk 1 and run LAUNCH.exe

   !!! Multiple server installation notes:
   - If you are installing **Centricity Practice Solution** using separate Database and Application servers, you must map a drive from the Application server to the location of the SQL setup.exe on the remote Database server. The default location is:
     
     C:\Program Files (x86)\Microsoft SQL Server\100\Release\Setup Bootstrap\setup.exe
   - The **Centricity Practice Solution** disc is inserted and launched on the Application server.

   Refer to Terminology on page 3 for server descriptions.

2. On the Welcome window, click **Copy DVD to hard drive**. This copies product files and installers to the server in preparation for installation or upgrade.

   Confirm that there is at least **2 GB** of free disk space for copying installation files to the server default path. If necessary, change the directory path.

3. Accept the default location (C:\CPS_xx_Staging) or enter a preferred location and click **Next**.

4. When the copy is complete, click **Finish** to close the window. Click **Exit**.

5. Use the Windows **Administrative Tools > Services** utility to Stop the **SQL Server Agent**.

6. Double-click the **CPS xx Launch** icon on the desktop, or navigate to the staging area (C:\CPS_xx_Staging) and double-click launch.exe.

7. Click **Install Server Prerequisites**.

8. Select your installation type to verify all prerequisites are installed. Fix any issues prior to continuing. Click **Next**.

9. On the Install/update server screen, click **ServerSetup**.

   The Install/update screen is accessed either by clicking **Next** on the Server Prerequisites screen, or by clicking **Install / update server** from the home screen of the Launch program.

10. Choose the setup option to perform. The choices are worded slightly different for the demo version.
   - Check **Install New Database**.
   - Select **Local Machine** if you are installing on a single server. Select **Remote Machine** when installing the database and Web site on separate servers.
   - Check **Install New Web Site**.
Click Next.

11 The prerequisites are checked on the server. If there are errors, correct them before you continue. If JBoss is not installed, an Install button appears and you are prompted to install it. Once the prerequisites are met, click Next.

JBoss is installed in the next step. Do not exit ServerSetup if JBoss is the only missing component. If you are missing other software prerequisites, click Exit and install the items noted on the screen, then restart the installation.

12 Click Install to install JBoss. Click OK to confirm install. When the JBoss install launches, click Next to install JBoss.

If the correct version of the Java Standard Edition Runtime Environment is not present, you are prompted to install it. Click Install to install the runtime environment.

13 Select the directory for JBoss and the Service Layer. Click Next to continue.

14 Enter the HTTP Port setting. For most sites the default port 9080 works correctly. Two ports are opened by the installer: 9080 and 9443 (9080+363). If you change the default 9080, the second port is then your selection +363. The ports are added to the Windows Firewall Domain Inbound Rule. Click Next to continue.

When the Setup Complete window opens, click Finish.

Wait until the JBoss Requirement status changes to Success before clicking Next.

15 The Setup Directory and Log file paths are displayed. The setup directory must point to the Install.inf file. Click the … button to navigate to the installation location if you did not use the default CPS_\_Staging location.

Click Next. If the log file directory does not exist, you are prompted to create it (click OK), or change the name to a different directory (click Cancel).
16 On the Server Logon window, do the following:

- Select or enter the name of the SQL Server where you want to install the database. The name should be in the form: server or server \instance if a named instance is used.

!!! The database server host name and the application server name cannot exceed 16 characters. Server names longer than 16 characters result in users not able to log in to the application.

- Leave the user name and password blank to use your current Windows administrator credentials.

- Click Next.

17 Enter the **Initial Patient ID Number** you want to use for the first patient in the system and click Next. Default value is 1.

18 For **Application Logon** and **Password**, enter a name and password for the Centricity Practice Solution application to use to access the database. Confirm the password and then click Next.

Note the SQL Server name and the application logon and password you created. You may need them later.

19 On the Database Name and Storage Devices window do the following:

- For **Database Name**, accept the default database name, or enter another valid SQL database name. By default, the database name you enter becomes the root name for the Data, Log, and Backup file names.

- For **Data (Path/Size)**, confirm the default path. For example:

  C:\Program Files (x86)\Microsoft SQL Server\MSSQL.10.MSSQLSERVER\MSSQL\DATA\centricityps.mdf

  Click the up-down control to change the default size of the data file.

- For **Log (Path/Size)**, confirm the default path. For example:

  C:\Program Files (x86)\Microsoft SQL Server\MSSQL.10.MSSQLSERVER\MSSQL\DATA\centricityps.ldf

  Click the up-down control to change the default size of the data file.

20 Click Next.

21 On the License Agreement window, select **I accept the end user license agreement and have authority to do so**, and click Next.
On the License Code window:

a Enter the **License Code** you were assigned when you purchased the product.

b Select a **Licensing Option**:

- **License over the Internet**. (Recommended). Select this option to verify your license code over the Internet.

- **Import a License File**. Select this option if you have been given a special use license from GE Technical Support. Click **Import a License File** to load it from the disk supplied by GE.

- **Training License**. This installs a practice database you can use to evaluate the product and prevents you from creating your own database.

c Click **Next**.

If you have purchased Crystal Reports integrated designer, you are prompted for the names of the workstation that utilize the Crystal Reports licenses. Click **Modify** to enter the workstation names. Click **OK** when finished.

On the Security window, select an authentication method (Application is the default). If you select Application, click **Next**.

If you select Active Directory,

a If needed, change the Active Directory domain controller to the desired domain in the Domain Controller field. The field defaults to the domain controller of the machine where ServerSetup is installed.

b In the Login Name field, enter the login ID of a user who is a member of the Domain Admins group in the selected Active Directory domain.

c Enter and re-enter the Active Directory password for the user in the Password and Confirm Password fields.

d Click **Verify Account** to determine if the entered credentials can be used to access Active Directory.

When clients request Active Directory user authentication or queries, the Service Layer will use the entered user credentials to access Active Directory. This account should be a permanent account, and should never be removed from the Domain Admins group in Active Directory.

If the Domain Admin user account is inactivated, or if the user’s login name or password changes in Active Directory, you must update ServerSetup with the new credentials to prevent authentication and querying failures.

If the credentials are accepted, a confirmation message appears at the bottom of the window in green text. If the credentials are denied, a message appears in red text, explaining the cause of the denial.
Installing Centricity Practice Solution

<table>
<thead>
<tr>
<th>Error Text</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unable to obtain the DNS Host Name. The Domain Name cannot be automatically provided.</td>
<td>You may not have logged in as a domain user.</td>
</tr>
<tr>
<td>Unable to obtain the default naming context. The Base DN information cannot be automatically provided.</td>
<td>The host computer may not have a connection to an Active Directory domain.</td>
</tr>
<tr>
<td>It does not appear that this computer belongs to a domain. The Domain Name, Security User DN and Base DN information cannot be automatically provided.</td>
<td></td>
</tr>
<tr>
<td>DNS computer names can contain only alphabetical characters (A-Z), numeric characters (0-9), the minus sign (-).</td>
<td></td>
</tr>
<tr>
<td>Password and Confirm Password do not match.</td>
<td></td>
</tr>
<tr>
<td>A Login Name is required.</td>
<td>The Login Name field cannot be blank.</td>
</tr>
<tr>
<td>ServerSetup was unable to verify the Active Directory Services Account.</td>
<td></td>
</tr>
<tr>
<td>ServerSetup was unable to collect needed information for the Active Directory Services Account.</td>
<td></td>
</tr>
<tr>
<td>A Domain Controller must be specified.</td>
<td>The Domain Controller field cannot be blank.</td>
</tr>
</tbody>
</table>

**e** (Optional) Click **Advanced** to launch a dialog where you can
- designate a base DN (such as an organizational unit), which must contain an Active Directory distinguished name. By default, this field is based on the domain controller name.
- edit the LDAP Query string

Editing the LDAP query string may potentially restrict the search results when searching Active Directory.

- Click **OK** to save your changes.
- You can reset the Active Directory information back to the defaults by clicking **Reset**.
- Click **Next**.

**24** If you selected to install a new web site as part of your installation: enter the Web site name. You can copy/paste the displayed default site name. Click **Next**. If prompted to create a `websitename.war` directory, click **OK** to create the site with the name you specified, or **Cancel** to change the name.

**25** Click **Next** to begin the installation.
ServerSetup begins installing the server and optionally the web site files if you selected to install a web site as part of the installation. Installation is complete when you see the **Database Installation Complete** message.

You have successfully installed the *Centricity Practice Solution* database and optionally the web site. Click **Exit** to complete the installation process, or **Return** to return to the ServerSetup application Welcome screen.

26 Use the Windows **Administrative Tools > Services** utility to ensure the **SQL Server Agent** is started.

**Install a web site**

Use this process if you did not create a web site when you installed the application or you are creating a new web site.

1 If ServerSetup is not open, double-click the ServerSetup icon on your Desktop or navigate to its location and open it.

2 On the ServerSetup window, select **Advanced Setup Options** and click **Next**.

3 Select Web Installation, then **Next**.

4 The prerequisites are checked on the server. If there are errors, correct them before you continue. If JBoss is not installed, an **Install** button appears and you are prompted to install it. Once the prerequisites are met, click **Next**.

5 Click **Install** to install JBoss. Click **OK** to confirm install. When the JBoss install launches, click **Next** to install JBoss.

   - If the correct version of the Java Standard Edition Runtime Environment is not present, you are prompted to install it. Click **Install** to install the runtime environment.

6 Select the directory for JBoss and the Service Layer. Click **Next** to continue.

7 Enter the **HTTP Port** setting. For most sites the default port **9080** works correctly. Two ports are opened by the installer: 9080 and 9443 (9080+363). If you change the default 9080, the second port is then your selection +363. The ports are added to the Windows Firewall Domain Inbound Rule.

   - HTTPS is required for web service access. All web service (service layer) calls now use HTTPS (SSL). This change requires the firewall settings on the JBoss server to be updated to open up port 9443 (or another https port if 9080 is not the default JBoss port). The firewall setting changes are performed as part of the installer.

Click **Next** to continue.
8 When the Setup Complete window opens, click Finish.

- If you are installing JBoss on a standalone server, you can increase the memory allocation. It is not recommended to increase it above 70% of your total available physical memory.

  By default, it is set to 45% of your total available physical memory. For example, with 4 GB of memory, the default setting is Xmx1843m.

  The basic procedure to change the allocated memory is:
  a Edit the file: install_dir\jboss\jsw\wrapper.conf
  b Locate the line: wrapper.java.additional.6=-Xmx1843m
  c Increase the default setting. For example: wrapper.java.additional.6=-Xmx2856m
  d Restart JBoss

  Refer to the System Planning and Requirements for Centricity Practice Solution for more information on JBoss and the wrapper.conf file.

9 Change the paths if you did not use the defaults when you installed the application. The setup directory must point to the WebInstall.inf file. Next to continue.

10 Enter the Web information:
  a Enter the name for the new web site.
  b Select or enter the name of the SQL Server where the database is installed.
  c Select or enter the database name.
  d Enter your SQL user name and password.
  e Click Next.

11 When prompted, click Next. The utility begins installing all web installation files. The Installation Complete window appears when the installation is complete.

  Click Return to return to the main menu or Exit to close ServerSetup.

  Additional web installations can be performed on separate servers using this same procedure.
Install Knowledgebase

Download the latest Knowledgebase and release notes from the Centricity Practice Solution Services Web site at http://centricitypractice.gehealthcare.com. Install the Knowledgebase using the installation instructions in the release notes.

Add application server name to local intranet

The application server name must be added to the Local intranet if you are going to run the client on a server. Some features, such as the growth charts or dosing calculators cannot access the server if it is not in the Local intranet group.
1. Open Internet Options from either Internet Explorer or the Control Panel.
2. On the Security tab, select Local intranet.
3. Click Sites...
4. Click Advanced...
5. Enter the application server name where the web site is installed, for example: http://server_name
6. Click Add. Close all of the various dialog boxes.

Install Clinical Content

If your site uses Clinical Content:
2. Download the Release Notes and the zip file for version 8.3.7.3 or later.
Install a workstation client

The workstation client can be installed from the media or from the Centricity Practice Solution web site.

For WTS/Citrix environments, follow the client instructions in the section Install client on the Remote Desktop Services/Citrix server on page 23

For Windows 7, Vista, and Server 2008 environments:
- Ensure Enable Protected Mode is off with all versions of Internet Explorer:
  a  Launch Internet Explorer.
  b  Select Tools > Internet Options and click on the Security tab.
  c  Select Local Intranet.
  d  Uncheck Enable Protected Mode.
  e  Restart Internet Explorer.

1  Start the install using one of the following methods:

From the media:
- a  On a workstation (or the server), insert the Centricity Practice Solution disc in the drive, and on the installer Welcome window, select Install Workstations / Workstation Components.
  If the Welcome window does not appear, double-click launch.exe on the DVD.
- b  On the Install Workstations / Workstation Components, select Install Centricity Practice Solution Workstation.

From the web site:
- a  Open a Web browser and type the URL for your Centricity Practice Solution Web site. For example, http://<server name>:9080/cps_web_site_name/cps/ Enter the cps_web_site_name all in lowercase.
- b  On the Update window under Client Setup, click the red install/update link.
- c  Wait for the Installing CPS_xx_Client page and click Install. Click Install if any Internet Explorer warnings are displayed.

From an existing client:
- a  Log into the application and click Product Updates on the application page.
- b  On the Update window under Client Setup, click the red install/update link.
- c  Wait for the Installing CPS_xx_Client page and click Install. Click Install if any Internet Explorer warnings are displayed.

Use the silent installer:
- Refer to Using the silent installer on page 22.

If you are prompted to install Microsoft .NET Framework, click Yes and accept the License Agreement. Reboot if prompted.
Install a workstation client

This launches the client installer. Wait for the Welcome window.

1. The Welcome window can be hidden behind the Internet Explorer window. Move the Internet Explorer window, or check your Windows Taskbar and click the InstallShield task to change the window focus.

2. On the client installer Welcome window, click Next.

3. On the Choose Destination Location window, accept the default installation directory or click Browse to install to a directory other than the default.

4. Click Next.

5. For Web site, enter the Web address you defined when you installed the Web site (for example, http://servername:9080/centricityps/cps where centricityps is the Web site name). The web site name must be entered in all in lowercase, exactly as shown.

6. Click Next.

7. Select one or more of the following options and click Next.
   - Select CPS xx Client to install the Centricity Practice Solution client application.
   - Select Data Transfer Station to automatically process HL7 data transfers between the EMR module and other healthcare information systems.

8. If you are prompted to install Microsoft .NET Framework, click Yes and accept the License Agreement. Reboot if prompted.

9. On the Start Copying Files window, click Next. The installation process copies the files to the workstation. If Data Transfer Station is selected, you are prompted whether this is the first CPS/DTS installation on the machine. Follow the prompts.

10. When installation is complete, click Finish. Click Exit or here if you upgraded with a browser. You can install/upgrade optional components from the browser. Once complete, exit the browser if used.

Launch the client from the workstation. Launching the client from an account with administrator privileges ensures that the registration runs correctly. This step is not needed if the user accounts have administrative privileges.

For workstations running Windows 7 or Vista, the CPS shortcut must be enabled to be run as the administrator. There are three methods to set this up:

- If the user has administrator rights, the shortcut and jobs.txt run correctly.
- Users can right click on the CPS shortcut and click Run as Administrator from the menu.
- The application can be set up to always run as administrator:
  - Right click the shortcut icon and select Properties.
  - Click the Advanced button to open Advanced Properties.
  - Check the box Run as Administrator.
  - Click OK to close the dialog boxes.

From now on, the application will always run as administrator if you use the shortcut to launch it. (You are prompted by UAC if you have it enabled).
Using the silent installer

There is a silent installation utility available on the media. Here is the basic procedure.

The workstations must already be updated to .NET 4.0 prior to running the utility. Any pre-9.x clients must be manually removed. The utility only removes 9.x and higher clients.

On the server:
1. Copy the Disk1 folder from the installation media to the server.
2. Share the server folder Disk1. You can not use a UNC path to run the silent installer. It must be on a shared drive.
3. Edit the file Disk1\CPS_xx_Client\setup.iss, where xx is the version number. Set the szDir and szEdit1 variables, substituting your installation information for the <variables>.

   szDir=<drive>\<install_path>\Centricity Practice Solution xx\Client
   szEdit1=http:\<server>:9080\<database_name>\cps

On each workstation:
1. Log in as administrator.
2. Open the mapped network drive from the server.
3. Double click silentinstall.bat, or right-click silentinstall.bat and use Run as administrator, depending on your operating system.

The silent install runs with only an installer icon visible in the system tray. When complete, a desktop shortcut is created using the URL specified by the szEdit1 variable in the setup.iss file.
Install client on the Remote Desktop Services/Citrix server

1. Log in as administrator at the Remote Desktop Services/Citrix server console.
2. Open a **Command Prompt** window.
3. Type the command:
   ```
   change user /install
   ```
4. Launch Internet Explorer, and enter the URL for the Centricity Practice Solution Web site (for example, http://servername:9080/centricityps/cps/ where centricityps is the Web site name) and follow the instructions for installing the client. The Web site name must be entered in all lower case.
5. When the setup program prompts you to do so, accept the default terminal description or supply a different description for this terminal, then click **Next**.

   Here are some sample terminal descriptions:
   
   **Clinic Manager–Bldg 2 Room 48, x5678, Eastside Med Asst. 2, x6179, Westside Lab 1, x5214, Rose Int. Med. Application Server for Centricity Practice Solution**

6. In the **Command Prompt** window, type the command:
   ```
   change user /execute
   ```

   When users run Centricity Practice Solution, the client name is appended to the workstation description. For more information, see “Identify each terminal with a unique ClientName variable name” on page 24. Here are sample full descriptions:

   **Application Server for CPS - FrontDesk48 Lab 1, x 5214, Rose Int. Med. - FrontDesk48**
Testing the Citrix client installation

Test that the client is installed properly and can connect to the database.

1 Test the installation:
   a Log in to the Remote Desktop Services/Citrix server as a regular user (not as admin).
   b Log in to Centricity Practice Solution using RDP or ICA, the thin client protocol. Select Start > Programs > Centricity Practice Solution > CPS Client.

2 Configure Remote Desktop Services users. When setting up users, configure how users connect to and disconnect from Remote Desktop Services sessions:
   n For On a Broken or Timed-Out Connection, choose the default Disconnect. This ensures that a broken or timed-out session will not be lost. Security may be maintained by limiting knowledge of the Citrix WinStation password, which is needed in order to reconnect. You may want to consider setting a time-out limit that eventually logs the user off.
   n For Reconnect Sessions Disconnected, choose From Previous WinStation Only. This forces the next login of a specific WinstationName (User ID) to connect to the previously disconnected session.
   n For other attributes, use defaults or set time-outs as desired for security purposes. Consider setting an idle user time-out.

3 Identify each terminal with a unique ClientName variable name. Centricity Practice Solution uses the environment variable ClientName to identify individual terminals. The administrator sets the client name for each terminal using a terminal-specific setup mechanism within the terminal.

Centricity Practice Solution requires that each terminal have a unique name.

4 Optimize server memory. To optimize server memory usage do the following:
   a Go to Start > Control Panel > Network and Internet > Network and Sharing Center.
   b Double-click on Local Area Connection and click Properties.
   c Select File and Printer Sharing for Microsoft Networks and click Properties.
   d On the Server Optimization tab, select Maximize data throughput for network applications and click OK and then exit the Control Panel.
Launch the Centricity Practice Solution client

1. Select **Start > Programs > Centricity Practice Solution xx > CPS xx Client**

2. Log in using a valid user name on the same domain as the client and database, or using the superuser account. The default superuser password is **superuser**, and upon logging in for the first time, the application asks for a new password for this account. The default password minimum length is 5 characters.

If your site is using Application authentication, changing the minimum password length will also affect the superuser account if you change that account password at a later time.

The superuser account will be locked out if the maximum number of failed login attempts is exceeded (the default is 3 attempts). You can unlock the account and reset the password back to the default on the Utilities window of ServerSetup.

The superuser account permissions are primarily restricted to the Administration permission node. The account has permanent Allow overrides for the Change System Settings permission and most Administration node permissions, with the following exceptions:

- New Batch
- Modify Batch
- Delete Batch
- Batch Closing
- Batch Closing Override
- Open Batch
- Close Batch
- Closing Date

Additionally, the superuser account cannot access the preference options and settings in

- **Administration | System > User and Resource Management > Users > Preferences > User Preference Groups**
- **Administration | System > User and Resource Management > Users > Preferences > User Preference**
- **Options menu item > Preferences.**
Next step: If you are installing the Centricity Practice Solution client for the first time on a workstation, launch the application and immediately do the following:

- Go to Administration > Users and Resource Management > Users > Security and set security settings for each anticipated user and security group of the product on the workstation. Failure to do this may prevent users from accessing components in upgraded versions, and prevents them from using the software for new installations.

- If your organization is using Application authentication, refer to the Centricity Practice Solution online help for information on creating and managing users. For Active Directory authentication, users must first be created in Active Directory before they can access the application. Refer to Microsoft’s documentation for instructions on creating and managing Active Directory users.

- If your organization is using Active Directory authentication and want the ability to automatically create new users and/or automatically synchronize security groups between Active Directory and the application, go to Administration > Users and Resource Management > Users > Security > Active Directory and select Auto Create Users and Auto Sync Groups. See the online help for more information about these features.

If you are using Active Directory authentication with the Automatically Sync Groups feature enabled, you must make sure that your Active Directory security groups are also recreated in the application database for successful synchronization. See the Centricity Practice Solution online help for more information on creating and automatically synchronizing security groups.
Import clinical kits

Clinical kits contain related clinical content that can be imported into or exported from the application as a group. A kit can contain whatever content as you want, such as document templates, encounter types, form and text components, and letter templates.

For a first time installation, import the Do first.ckt, upgrade.ckt and doctemps.ckt kits.

The Observation Term kit is required. Download and import the latest factory observation term kit from the support site: http://centricitypractice.gehealthcare.com/

Refer to the application online help topic “Import clinical kits” for details. The basic procedure for importing a kit is:

1. Launch the application from the server where you installed the application and log in as an administrator.
2. Click Administration.
3. Go to System > Import Clinical Kits.
4. To import a kit, select Import Clinical Kit.
5. Browse to the kit location. This can be the network staging directory, a local or network drive, or the KnowledgeBank web site. Refer to the help topic for more information.
6. Select the kit file (with an extension of *.CKT) and select OK.
Install optional server software

You can install the following optional components:

- Web installation on a separate server. Use the procedure Install a web site on page 17.

- Data Transfer Station (DTS) automatically processes HL7 data transfers between Centricity Practice Solution and other information systems such as laboratories, hospitals, or transcription services. DTS can be installed on one of the servers or a dedicated workstation.

- Millbrook Integration Kit (MIK) enables Centricity Practice Solution to share data with other information systems. MIK can be installed on one of the servers or a dedicated workstation.

- Client workstation installs a CPS client on the application server for easy testing. If you are planning on running the Centricity Electronic Medical Record 9.x client on the same workstation as the Centricity Practice Solution 9.x client, you must install the EMR client on the workstation first.
About Data Transfer Station (DTS)

- DTS runs as a client application on the workstation where it is installed.
- DTS can run concurrently with the Centricity Practice Solution client application.
- Multiple DTS can be configured to run on a single client workstation as separate instances. The DTS shortcut created during installation includes "instance=1" at the end of the target path (in Properties). For each additional DTS, you must manually copy the shortcut and increment the instance number (for example, instance=2).

⚠️ You must be licensed for both CPS and LinkLogic to use Data Transfer Station. DTS is not supported in Windows Remote Desktop Services environments.

**Importing:** DTS looks in the LinkLogic inbox for incoming data files (jobs) waiting to be processed, then sorts the jobs into task queues such as importing demographics data or lab reports. Next, DTS processes each queue. You control which tasks a DTS processes and how often it processes them.

Multiple Data Transfer Stations can import the same type of information. For example, Demographics.

**Exporting:** Automatically sending information from Centricity Practice Solution is simple: DTS puts the job in the LinkLogic outbox. The files are then transferred using one of the following methods:

- TCP/IP
- Sockets
- Another third-party transfer mechanism, such as an interface engine
- DTS is either installed on a dedicated workstation (EMR only) or on a workstation with Millbrook Interface Kit (MIK). You can have more than one DTS set up to import or export specific types of data.

Multiple Data Transfer Stations cannot be assigned the same export task. Each LinkLogic export task can be assigned to only one DTS.

Refer to Managing interfaces with Centricity Practice Solution for detailed interface specifications and an overview of day-to-day LinkLogic/DTS management tasks.

Share the LinkLogic directory

LinkLogic is installed on either a Data Exchange server or on the primary DTS dedicated workstation. If you use a workstation, Windows 7, Vista, and XP only allow 10 concurrent connections. The LinkLogic directory is shared, to be available to clients and multiple DTS stations. Use a UNC path, not a mapped drive.

1. Navigate to `\Program Files (x86)\Centricity Practice Solution xxx\Client`
3. Select Share this folder. Click OK.

⚠️ If you have a previous version of the LinkLogic directory stored on the Database server, copy the `\logic\config` folder and paste it in the new shared `Illogic` directory.

Use the shared network folder for all of the DTS inboxes.
Installing Centricity Practice Solution

Understanding DTS Inboxes

If more than one DTS imports the same type of information, they must have unique Inboxes. For example, if DTS-1 imports demographics and DTS-2 imports lab results, they can share the same Inbox. However, if DTS-1 and DTS-2 both import demographics, they must have unique Inbox locations. For example:

\dts_server\logic\data\in\DTS-1-Demographics
\dts_server\logic\data\in\DTS-2-Demographics

For maximum performance, each DTS should have its own Inbox on the shared network logic folder.

Install Data Transfer Station (DTS)

Confirm the workstation meets the hardware requirements for Data Transfer Station. After installation you must configure one or more stations on the client workstation to process data transfers. You cannot launch the DTS until all configuration is complete. Perform these steps while connected to the console of the DTS station.

1 Insert the Centricity Practice Solution installation disc in the workstation drive. On the Welcome window, select Install optional components and then click Install Data Transfer Station.

   If the Welcome window does not appear, double-click launch.exe on the CD.

2 On the installer Welcome window, click Next.

3 On the Choose Destination Location window, accept the default installation directory or click Browse to install to a directory other than the default.

4 Click Next.

5 For Web site, enter the Web address you defined when you installed the Web site (for example, http://<server name>:9080/your_CPS_web_site_name

6 Click Next.

7 Confirm that both Client Workstation and Data Transfer Station are checked. The Centricity Practice Solution client is required to run Data Transfer Station.

8 Click Next.

9 If you are prompted to install Microsoft .NET 1.1 Framework, click Yes and accept the license agreement. Reboot when prompted. This component is required.

10 On the Start Copying Files window, click Next.

   A DTS shortcut is added to the Start > Programs > Centricity Practice Solution xx menu. This launches the DTS application once a DTS has been created and configured in Administration.

11 When complete, remove the installation media.

12 Edit the CPS 9.x icon properties to have the DTS start up without a login prompt.

   a Right click on the CPS 9.x icon and select Properties.

   b Add -U after the web site address in the Target box. For example:

      "C:\Program Files (x86)\Centricity Practice Solution XX\Client\ml3dts.exe"

      "http://hcu-64slmh1:9080/demo/cps/" -U instance=1

   c Click OK.
Set up a Data Transfer Station

1. Double click the desktop icon to launch Centricity Practice Solution. Log in as an Administrator.

2. Open Administration and select System > LinkLogic > Defaults.

3. Check Automatically Queue Jobs.
   
   If you clear this option, DTS does not scan the inbox for new jobs.

4. Enter the frequency time and units in Queue Jobs Every for often DTS should scan the inbox.
   
   GE recommends that you set up DTS to scan the inbox as often as your most frequent recurring task.

5. Enter the alert time and units for monitoring no activity in the DTS Monitor Threshold. Alerts are displayed on the Monitor tab on the DTS workstation.

6. If you are going to run DTS as a Windows service, check Disable all LinkLogic/DTS startup dialogs to permit the DTS to restart automatically without user intervention.
   
   If the DTS cannot restart successfully, temporarily clear this option so you can see an error or warning that may be preventing restart.

7. From Administration, select System > LinkLogic > Stations.

8. In the Stations list, click New DTS...

9. Add the new station description and identifier. Verify the network locations for the Inbox and LinkLogic folder are correct. Be sure and create all inboxes in the shared LinkLogic folder.

10. For Tasks, select the tasks that you want this DTS to process.

11. Click OK.

12. Double click the DTS icon. It should start without any errors.

13. Log into your DTS and verify messages import successfully.
Troubleshooting the DTS

Possible issues that may occur that could be related to DTS\LinkLogic configuration.

- When opening up the DTS application or Chart component you receive a prompt to browse for the lLogic folder. This indicates the share permissions on the lLogic folder are not allowing users to connect to the share. Confirm that the lLogic share is available from this workstation. Check the LinkLogic > Defaults in Administration to see where the Network lLogic share is set.

- When opening up the DTS application or Chart component you receive a message that the versions do not match and it asks you to browse for the lLogic folder. This indicates that the Network lLogic share has not been updated with the CPS 9.x Standard and Upgrade folders. There are version specific files contained within these folders.

- When starting the DTS, you receive a message that this machine has not been configured as a DTS workstation. This indicates the emr.ini file does not contain the configuration information for the DTS. Copy the configuration into the file or rebuild the DTS within the CPS 9.xclient.

Running the DTS as a Service

You can configure Data Transfer Station to run as a Windows Service, allowing the LinkLogic Manager to start, stop, and check the status of the DTS from the Administrative Tools > Services control panel. If the DTS crashes, the new service restarts it automatically.

GE does not recommend or support running multiple instances of DTS on a single workstation when running DTS as a service.

Install and start the LinkLogicDTS service

1. Navigate to the installation directory.
2. Double-click the dts_install.cmd file.

   If you are running on an operating system with User Access Control, such as Vista, Windows 7, or Server 2008, right-click the file and select Run as administrator. Click Continue at the User Access Control (UAC) dialog.

3. To start the service, from the Start menu, go to Administrative Tools > Computer Management > Services and Applications > Services.
4. Right-click on the LinkLogicDTS service and select Start. The LinkLogicDTS service starts the Data Transfer Station automatically when you reboot the machine.

   When you have the DTS configured to start and run as a Windows service, never start the DTS manually from the command prompt.

Start the Microsoft Services Interaction Detection service

For operating systems such as Windows 7, Windows Vista, and Windows Server 2008, you must start the Microsoft Services Interaction Detection service in order to run DTS as a service. The LinkLogicDTS service must be started first.
Configure the service to run under a user account

For processes created by the service to access a specific user's settings such as mapped network drives, you must configure the service to run under a user account. After starting the LinkLogicDTS Windows Service, perform the following steps:

1. Click Start > Administrative Tools > Services.
2. In the installed services list, double-click LinkLogicDTS.
3. In the Services Properties window, select the Log On tab.
4. Check Local System Account and Allow service to interact with Desktop.
5. Click OK.

Disable LinkLogic/DTS startup dialogs

To permit a fully automatic restart, you must disable all LinkLogic / DTS startup dialogs that force the launch of the Logon/Password dialog and require user intervention.

1. From the Centricity Practice Solution client, open Administration and select System > LinkLogic > Defaults.
2. Check Disable all LinkLogic / DTS Startup Dialogs.

The DTS will now restart automatically in the event of a crash.

Uninstall the LinkLogicDTS service

1. Stop the LinkLogicDTS service.
2. Navigate to the installation directory.
3. Double-click the dts_uninstall.cmd file.
Install Millbrook Integration Kit (MIK)

Millbrook Integration Kit (MIK) is a service that shares patient and financial data used by the practice management module with external applications and plug-ins. MIK uses the MS-HUG ActiveX for Healthcare messaging system and uses HL7-compliant messages. For detailed interfaces specifications see Managing interfaces with Centricity Practice Solution available in the Centricity Document Library or on the Web site at http://centricitypractice.gehealthcare.com.

MIK requires a separate license. For licensing information, please contact your Value Added Reseller or a GE Sales Representative.

Installing, configuring, and licensing MIK should be performed by users with a thorough knowledge of interfaces, the operating system, and network connectivity.

To configure MIK to integrate with specific non-GE applications, see MIK Integration Tech Notes. Click a link for the system you want to integrate with to download Adobe PDF format instructions.

!!! This site is password-protected. To obtain a login name and password, call Centricity Services at 888.436.8491, option 2.

Before installing MIK to a workstation, confirm that it meets the hardware requirements for MIK.

1. To install MIK, do one of the following:
   - Insert the Centricity Practice Solution installation disc in the workstation drive. On the Welcome window, select Install optional components and then click Install Millbrook Integration Kit (MIK). If the Welcome window does not appear, double-click launch.exe on the CD.
   - If you are installing MIK as part of the server installation, the Install optional components and then click Install Millbrook Integration Kit (MIK).

2. On the Welcome window, click Next.

3. Use Browse to select the drive and directory, or accept the default ..\Centricity Practice Solution xx\CPS_xx_MIK\ then click Next.

4. To start copying files, click Next.

5. When the installer displays Setup Complete, select Finish to exit setup.

6. Reboot your system. You cannot configure MIK until you reboot the system.
About browser/mobile access installation

This feature is automatically installed and configured as part of the installation or upgrade process. This section provides an overview of that configuration. For complete information and security considerations, refer to “Security considerations for browser and mobile access” and “Maintaining JBoss/Service Layer” in the Systems Requirements Guide.

The browser and mobile access feature uses the existing service layer deployment and two new deployments that build on top of the service layer. It can be configured on one server to connect to multiple database instances. The user selects which database instance they access by referencing the URL for that instance.

The basic URL pattern is:
http://servername:port/database_name/emrgwt/Emr.html

Where servername, port, and database_name are all specified during the installation process. In this example, servername is server1, port is 9080, and the database_name is cps1:

http://centricityserver:9080/cps1/emrgwt/Emr.html

Distribute this URL to all browser and mobile access users.

The filename Emr.html is case sensitive.
Configuring browser/mobile access for users

Configuring user access and MQIC (if your site participates in the MQIC consortium) is performed within the application. Refer to the online help topics Assign access to patient charts and Enter application user security.

To configure users for browser/mobile access:

1. Go to Administration > System > User and Resource Management > Users > User Management. For each user:
2. Select user.
3. Click Edit...
4. On the Security tab, expand Web Services in the permission list.
6. On the Chart Access tab, enter the MQIC User Name if used.
7. Click OK.

To configure MQIC:

1. In the main application, go to Administration > Charts > MQIC.
2. Click Enable MQIC.
3. Enter the Web Service URL.

Testing browser/mobile access

As part of the final installation or upgrade steps, test the web access:

1. Open a supported browser.
2. Enter the application URL as described in this section. The application login is displayed. You can not log in until browser/mobile access is enabled for the user.
3. Optional: Enable access for a test user. Login as the test user and view a patient chart.
Enabling attachment viewing

To properly display internal attachments, a third party package, LEAD command line utils, is required. This package is available from www.leadtools.com. For additional details, refer to http://www.leadtools.com/Utilities/Cmd-Line/File-Converter/

1. Install the LEAD command line utils on the same server as JBoss.
2. Copy the file c:\leadtools\lfc.exe to the directory c:\leadtools\bin
3. Update the system path to include c:\leadtools\bin
4. Restart the server.
5. Optional: Enable access for a test user. Login as the test user and view an internal attachment via browser /mobile access. Refer to Configuring browser/mobile access for users.

Displaying external attachments has the following conditions:

- Content must be accessible by the JBoss server via the file system, or the network using http or https protocol.
- Browser must be capable of displaying the content. For example, even simple files like .pdf require a plugin or software to display correctly.
- Attachments like PDF, Microsoft Excel, or Microsoft Word documents are passed through the server to allow authenticated users to view content.
- Complex web pages that reference external images may not display correctly since the secondary image content may not be accessible from the client in the customer configured network topology.

The browser may save the content to disk and could open the content in a new browser window. It is the responsibility of the user to avoid leaving windows open, or leaving attachment files on the client disk drive where they could be accessed by unauthorized personnel.
Configuring webcams for Windows 7 or Vista operating systems

In Windows 7 and Vista operating systems, User Account Control (UAC) prevents Centricity Practice Solution from importing images via the Webcam button on the Acquire Photo window.

A Windows 7 or Vista-compatible webcam device is required for the following workarounds.

Workaround 1: Turn off User Account Control (UAC)

Turn off User Account Control (UAC) for each user who must use a webcam. Turning off UAC must be performed by an administrator.

2. Click Turn User Account Control on or off and then confirm your selection.
3. Click Continue.
4. On the Turn on User Account Control (UAC) window, uncheck Use User Account Control (UAC) to help protect your computer.
5. Click OK.

You must restart the computer for this change to take effect. Click Restart Now to immediately restart your computer, or Restart Later to continue working without restarting.

Workaround 2: Use the Camera button

For webcams that can also function as digital cameras, on the Acquire Photo window, select Camera instead of Webcam to capture images in Centricity Practice Solution.

See your camera’s documentation or manufacturer to determine whether your webcam will also function as a digital camera.

Workaround 3: Capture images outside the application

Capture images outside Centricity Practice Solution. Then, on the Acquire Photo window, select File or Clipboard to import the images into the application.
Setting up user security

Security rights determine whether you can access and take actions in Centricity Practice Solution components and sub-components. For example, you can access a visit, but your security settings may prevent you from modifying or deleting it.

A user with rights to the Administration module (usually the System Administrator) can set up user security. An Administrative user must have all security permissions to grant them to other users.

To access the help for the Administration module:

1. Start the application.
2. Select Administration
4. Press F1

At a minimum, set up the following:

- Users
- Administrative Users
- User Security
- Chart Permissions

ServerSetup online help

Refer to the ServerSetup online help for information on the included utilities and advanced ServerSetup options.

Anti-virus software

GE recommends you use well-known commercial anti-virus software on all workstations. GE has tested compatibility with Symantec AntiVirus™ and Sophos anti-virus, anti-spam and client firewall.

Anti-virus software can impact the performance of your database software running on the server. Full virus scanning should not occur during peak system usage times.

To maintain reliable performance and help ensure protection of Protected Health Information, exclude directories that contain SQL Server database files.

Requirements for disabling anti-virus software during installation and upgrade are specified as part of the procedures in this guide, and in the System Planning and Requirements for Centricity Practice Solution guide.

If performance slows down, and the SQL Server is consuming most of the CPU utilization, reboot the server.
Install biometric authentication

Biometric Authentication helps verify a user biometrically when faxing prescriptions to a pharmacy. To use Biometric Authentication, you must connect a finger reader device to your workstation. The supported reader is the digitalPersona Uare.U Fingerprint Reader. You need to complete the Biometric configuration and registration to use it. For more information on the device visit:

http://www.digitalpersona.com/products/dpFingRead.php

!!! The digitalPersona runtime environment is custom built for GE. Do not download the standard version from the digitalPersona web site.

For configuration and usage information, refer to these topics in the online help:

- Set up prescription requirements
- Register fingerprint
- Use biometric authentication
- Logging events

There are multiple deployment methods for the biometric runtime environment:

- Stand alone deployment. The runtime environment is installed on the same workstation that is running the Centricity application.
- Remote desktop deployment. The runtime environment is installed on both the client and the dedicated server.
- Citrix deployment. The runtime environment is installed on the Citrix server and all Citrix clients that access the fingerprint reader.

The installer is located in the Centricity staging directory Biometric folder. For example:

\CPS_90_Staging\Biometric\Setup.msi
Install biometric authentication

Stand alone deployment
The runtime environment is installed on the same workstation that is running the Centricity application.

1. Copy the specified file from the staging area Biometric folder to the workstation: digitalPersona: Setup.msi
2. Double click the install file to begin the installation.
3. Follow the prompts for the installation.
4. Restart the workstation when the installation is complete.

Remote desktop deployment
The runtime environment is installed on both the client and the dedicated server.

Only the digitalPersona reader runs under this configuration.

1. Copy the Setup.msi file from the staging area Biometric folder to the workstation.
2. Double click the Setup.msi file to begin the installation.
3. Follow the prompts for the installation.
4. Restart the workstation when the installation is complete.
5. Repeat steps 1 through 3 on the server and restart the server.

Citrix deployment
The runtime environment is installed on the Citrix server and all the Citrix clients that access the reader.

1. Copy the Setup.msi file from the staging area Biometric folder to the Citrix server hosting the Centricity client and to each workstation with Citrix clients that access the fingerprint reader.
2. Double click the Setup.msi file to begin the installation. The file must be installed on the Citrix server and on all Citrix clients that access fingerprint readers.
3. Follow the prompts for the installation.
4. Restart the workstation when the installation is complete.
5. Repeat steps 1 through 3 on the Citrix server and restart the Citrix server.

Registering DPICACnt.dll for each Citrix client

1. Copy the DPICACnt.dll file from the staging area Biometric folder containing the Citrix client. For example: Program Files\Citrix\ICA Client
2. Register the dll using the full path. For example:
   regsvr32 C:\<Program Files\Citrix\ICA Client>\DPICACnt.dll
Installing Centricity Practice Solution

About the Demo (evaluation) Database

You can install the Demonstration version of the Centricity Practice Solution server with a demonstration database and Web site to evaluate or learn about and practice using Centricity Practice Solution features.

The Demo Database includes practice patients, users, security groups, and charts. Centricity Practice Solution is web-enabled, so users can access the application and Demo Database from a workstation via the Internet or your Intranet.

The Centricity Practice Solution application and Demo Database and Web site can be installed on a Windows Server. Refer to Configuring Environments for Centricity Practice Solution for minimum database engine and hardware requirements.

You can log into the Demo Database as a training user in a variety of job roles. For example, users hwinston and kstarr have a default password of asdf. These demo users are set up as a system managers. Additionally, you can log into the Demo Database using the superuser account (with the default password of superuser for the initial log in) to perform administrative functions such as setting security or creating users.

The application includes an option to manage Demo Database user logins using Application authentication. This option uses the training user information noted above for user authentication. Using this option helps you avoid mixing training user identities with real users in Active Directory.

Install a demo database and Web site

1. Insert the Centricity Practice Solution installation disc in the drive. If the Welcome window does not appear, double-click launch.exe on the disc.

2. On the Welcome window, click Copy CD to hard drive.

3. Accept the default location or enter a preferred location (default is C:\CPS_xx_staging\) and then click Next. The installation files are copied to the server hard drive. When copy is complete, a Welcome window appears with new options.

4. To confirm installation of all required software, click Install Server Prerequisites to check your system.

5. Select Install single-user evaluation version. The installer checks requirements for you. Follow on-screen instructions to update your server or workstation with required software.

6. Click Back to return to the Welcome window, then click Install / update server.

7. Click ServerSetup.

8. On the ServerSetup window, select Demo, then Next.
Confirm that both Install Demo Database and Install Demo Website are checked and then click Next.

ServerSetup checks the Web server for minimum hardware and software requirements for a combined database/Web server. Checks that failed or installations required are displayed on the screen. Click Report for details.

If you are missing any software prerequisites for the Web server, exit the Server setup application and install items noted on the screen.

On the Setup Directory Path and Log File Path window, do the following:

- Confirm that Setup Directory Path points to Demo.inf or click ... to navigate to its location on the hard drive. Default is C:\CPS_xx_staging\SS\Demo.inf.
- Confirm the location of the server setup log file for this installation. Click Next.

On the Server Logon window, do the following:

- Select or enter the name of the SQL Server where you want to install the database.
- Enter your SQL user name and password, and click Next.

On the Application Logon and Password window, enter a logon name and password for the Centricity Practice Solution application to use to access the database. Confirm the password and then click Next.

On the Database Name and Storage Devices window, do the following:

- For Database Name, accept the default database name, or enter a different name. By default, the database name you enter becomes the root name for the Data, Log, and Backup file names.
- For Data (Path/Size), confirm the default path for the data file. For example D:\Program Files (x86)\Microsoft SQL Server\MSSQL0.MSSQLSERVER\data\demo.mdf. Do not change the default size of the data file.
- For Log (Path/Size), confirm the default path for the error log file. For example D:\Program Files (x86)\Microsoft SQL Server\MSSQL0.MSSQLSERVER\data\demo.ldf. Do not change the default size of the data file.

Click Next.

On the License Agreement window, Select I accept the end user license agreement and have authority to do so, and click Next.

On the License Code window, select Training License and click Next.

This installs a practice database you can use to evaluate the product or to practice using demo data. It prevents you from creating your own database.
In the Web site Information window, do the following:

- For Virtual Directory, confirm the default or enter a different name. This name is used in the Centricity Practice Solution Web site’s address.
- For Install Location, select or enter the file path where you want the program files to be installed. The default is: \Program Files (x86)\Centricity Practice Solution xx\demo

Click Next.

ServerSetup begins installing the server and Web site files. Installation is complete when you see the message Database Installation Complete.

Click Exit to complete the installation process, or Return to return to the ServerSetup window.

Renaming the Demo installation

It is useful to rename a Demo installation to easily differentiate it from a production installation if you are running both types at the same time.

This procedure modifies a file on your Application Server. The modification of this file should only involve a change to the row noted with no additional spaces or carriage returns added.

This procedure can be performed with the assistance of GE personnel.

1. Browse to the JBoss website folder on your Application Server. The default path is: \Program Files (x86)\Centricity Practice Solution xx\JBoss Application Server\jboss\server\default\deploy\WebsiteName.war
2. Make a backup of the config.xml file.
3. Open config.xml with a text editor.
4. Locate the Caption row and add TEST:
   
   <Caption>TEST</Caption>
5. Save and exit. Make sure the file is saved with the .XML file extension.
6. Login to the application. Launch each component and note the blue title bar is prefaces with TEST. If this is not successful, delete the modified file and rename your backup file to be config.xml to restore the default.

Setting user permissions

In Windows XP, a standard user has read and write permission on the C:\ drive. This is not the default on Windows 7, Windows Vista and Windows Server operating systems. To ensure standard users can run the evaluation version, set the user permissions on the Centricity installation directory.

If the permissions are not set, and fatal error is displayed during file read and write operations when launching the client.

1. Login as administrator.
2. Give users full permission to the folder where the Centricity client is installed. The default directory location is under C:\Program Files.
About ServerSetup product updates

From ServerSetup you can download and apply available product updates and service packs.

If your site uses a proxy server to access the internet, you must set up the proxy server for the JBoss application server from ServerSetup:

**Advanced Setup Options > Web Proxy Server**

Refer to the online help for details.

Depending on how your site is set up, you may have to set up the proxy for each workstation to be updated.

**Download Available Updates** opens a secure web site containing all available update packages for server, Web site, and workstations. Select an update to download.

**Apply Available Updates** installs selected updates to the server, Web site, or workstation.

You can access this feature only after you have successfully downloaded the updates.

Selecting **Download Available Updates** in ServerSetup lets you access the Product Update website displaying updates available for the current version of your Web site.

You can also accomplish product updates in the following ways:

- From the product update web site. This is the easiest, most automated installation/update. Just login in to the application and click **Product Updates** on the CPS main page.

- From the installation CD. When you need to install required or optional software for the application or add a single workstation or at remote sites where updates over the Internet might be too slow.
Installing Centricity Practice Solution

Download updates via ServerSetup

From ServerSetup, you can access a secure Web site to download available update packages for server, Web site, and workstations.

- ServerSetup must be installed on the server where the Web site is installed.

1. Double-click the ServerSetup icon on your Desktop or navigate to its location and open it.
2. Select Download Available Updates, and then click Next.
3. Select the Web site you want to check for updates, confirm the log file path, then click Next.

!!! Clicking back removes any downloads you have selected.

4. Select an update to begin downloading. The Downloading Update window displays the product version, download location, and progress.
5. If the download is unsuccessful (Download Failed), click OK. After this, click Cancel to return to the Available Updates window and do the following:
   - Select another download
   - Click Exit to leave the update Web site
   - Click Back to return to previous ServerSetup screen.
6. If the download is successful (Completed), click OK. Do the following:
   - Select another download
   - Click Finish if you are ready to apply downloaded updates.
   - Click Exit to leave ServerSetup. You can return to ServerSetup later to apply the download.
Apply updates via ServerSetup

Downloading updates activates the **Apply Available Updates** button. You can install an update immediately after download or exit ServerSetup and apply updates later.

| ✅  If you are upgrading and have copied installation files to the server hard drive, you can apply the upgrade from **Apply Available Updates**. |

1. Double-click the **ServerSetup** icon on your Desktop or navigate to its location and open it.
2. Click **Apply Available Updates**, and click **Next**.
3. On the Secure Web site Installation window, select the Web site you want to apply updates for and confirm the log file path, then click **Next**.
4. On the Server Logon window, select/confirm the **SQL Server** where you want to update a database, enter your **SQL user name** and **password**, and click **Next**.
5. Click **Next** again to begin installing the update.
   When the update is complete (**Action completed!**), the **Next** button text changes to **Return**.
6. Do the following:
   - Click **Exit** and confirm to leave ServerSetup
   - Click **Return** to return to the first ServerSetup screen.
Remove the client from a workstation

Use this procedure to remove the Centricity Practice Solution client:

1. If you store custom reports or other files, move or back up these files before you remove the application.
2. Exit all open programs.
3. Perform one of the following:
   - For workstations **not running** Windows 7 or Vista, select
     
     **Start > Programs > Centricity Practice Solution xx > CPS xx Setup**
   - For workstations **running** Windows 7 or Vista, start the Windows Control Panel. For example:
     
     **Start > Control Panel > Programs > Uninstall a program**
     Select **CPS_xx_Client**
     Click **Change/Remove**
   - Run the silent uninstaller. Refer to Using the silent uninstaller on page 49.
4. When you see the Welcome message, select **Remove** then click **Next**.
5. Confirm that you want to remove the application by clicking **Yes**.
6. Wait while the setup program removes the application.
7. When the process is complete, click **Finish**.
8. Locate the Centricity Practice Solution program folder and delete it. Default location is **C:\Program Files (x86)\Centricity Practice Solution xx**.

!!! Before deleting this folder, check for custom reports, saved versions of the database, and other files you want to save.
Using the silent uninstaller

There is a silent uninstall utility available on the media. You must use the same media version you used to install the application. Here is the basic procedure.

The workstations must already be updated to .NET 3.5 or higher prior to running the utility. Any pre-9.x clients must be manually removed. The utility only removes 9.x and higher clients.

If you used the silent installer, the server steps may already be complete.

On the server:

1. Copy the Disk1 folder from the installation media to the server.
2. Share the server folder Disk1. You can not use a UNC path to run the silent uninstaller. It must be on a shared drive.

On each workstation:

1. Log in as administrator.
2. Open the mapped network drive from the server.
3. Double click silentuninstall.bat, or right-click silentuninstall.bat and use Run as administrator, depending on your operating system.

The silent uninstall runs with only an uninstall icon visible in the system tray.

Documentation survey

Help us improve our customer documentation. All responses are confidential. A brief documentation survey is available at:
